blogをはてなから自前構築のブログにしてみたいと思ってのですが(Ruby使ったフレームワークで)、Jekyll, Octopressが流行り?に乗っかって構築してみます。

つまづいたのは、よくあるようでrakeのversion違いに。しょうがないからrakeのコマンドは以下で実施、めんどくさい。

$ bundle exec rake ...

以下のエラーについては

rake aborted!
You have already activated rake 10.1.0, but your Gemfile requires rake 0.9.6. Prepending `bundle exec` to your command may solve this.

素直に

$ bundle exec rake install

していきましょう、ということか。

はてなブログにはエクスポート機能が無い、だと…?

テーマは http://opthemes.com/ を確認。
とりあえずこちら https://github.com/bkutil/bootstrap-theme で設定

$ git clone git://github.com/bkutil/bootstrap-theme.git .themes/bootstrap-theme
$ bundle exec rake install['bootstrap-theme'] 
$ bundle exec rake generate # これも忘れずに
$ bundle exec rake preview

もうちょっと簡単に変えたいね…

コメントは disqusに登録し、_config.ymlにユーザ名記入するだけでライトに構築できてしまう…すげえなあ。

localリポジトリのmasterはoctopressのmasterと同期ということにして、editlineブランチをheoku:masterとしてpushする

$ git push heroku editline:master

Comments